$re = '/(?:^declare -a IP_LIST=\(|(?!^)\G)\s*\'([^\']+)\'(?=[^()]*\))/m';
$str = 'declare -a IP_LIST=(
\'x.x.x.x/24\'
\'x.x.x.x/24\'
\'x.x.x.x/24\'
\'x.x.x.x/24\'
\'x.x.x.x/24\'
\'x.x.x.x/28\'
)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);