const regex = /https?:\/\/([^\s]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/([^\\s]+)', 'g')
const str = `https://site.ru/{% if type == 'webinar' %}webinar{# comment #}{% else %}profile{{ type }}{% endif %}?utm_source=email&utm_medium=[UTM_MEDIUM]
https://site.ru/{{ type }}
https://site.ru/?utm_source=email&utm_medium=[UTM_MEDIUM]
https://site.ru/link
текст текст https://site.ru/{% if type == 'webinar' %}webinar{# comment #}{% else %}profile{{ type }}{% endif %}?utm_source=email&utm_medium=[UTM_MEDIUM] текст текст https://site.ru/{{ type }} текст текст https://site.ru/?utm_source=email&utm_medium=[UTM_MEDIUM] текст текст https://site.ru/link`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}