re = /https?:\/\/([^\s]+)/
str = 'https://site.ru/{% if type == \'webinar\' %}webinar{# comment #}{% else %}profile{{ type }}{% endif %}?utm_source=email&utm_medium=[UTM_MEDIUM]
https://site.ru/{{ type }}
https://site.ru/?utm_source=email&utm_medium=[UTM_MEDIUM]
https://site.ru/link
текст текст https://site.ru/{% if type == \'webinar\' %}webinar{# comment #}{% else %}profile{{ type }}{% endif %}?utm_source=email&utm_medium=[UTM_MEDIUM] текст текст https://site.ru/{{ type }} текст текст https://site.ru/?utm_source=email&utm_medium=[UTM_MEDIUM] текст текст https://site.ru/link'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end