#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*ext[2-4]|.*xfs)(\s+)((([a-zA-Z\=\-]+)(?!noatime,nodireatime)).+)"
Local $sString = "# Not match" & @CRLF & _
"/dev/mapper/VolGroup00-root / ext4 errors=remount-ro,noatime,nodiratime 0 1" & @CRLF & _
"/dev/mapper/VolGroup00-home /home ext4 defaults,noatime,nodiratime 0 2" & @CRLF & _
"LABEL=cloudimg-rootfs / ext4 defaults,noatime,nodiratime 0 0" & @CRLF & _
"" & @CRLF & _
"# /etc/fstab: static file system information." & @CRLF & _
"#" & @CRLF & _
"# Use 'blkid' to print the universally unique identifier for a" & @CRLF & _
"# device; this may be used with UUID= as a more robust way to name devices" & @CRLF & _
"# that works even if disks are added and removed. See fstab(5)." & @CRLF & _
"#" & @CRLF & _
"# <file system> <mount point> <type> <options> <dump> <pass>" & @CRLF & _
"/dev/mapper/VolGroup00-root / ext4 errors=remount-ro 0 1" & @CRLF & _
"# /boot was on /dev/sda1 during installation" & @CRLF & _
"UUID=72836e37-44d4-4612-90ef-0e545a0071a6 /boot ext4 defaults 0 2" & @CRLF & _
"/dev/mapper/VolGroup00-home /home ext4 defaults 0 2" & @CRLF & _
"/dev/mapper/VolGroup00-tmp /tmp ext4 defaults 0 2" & @CRLF & _
"/dev/mapper/VolGroup00-var /var ext4 defaults 0 2" & @CRLF & _
"/dev/mapper/VolGroup00-swap_1 none swap sw 0 0" & @CRLF & _
"/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0" & @CRLF & _
"" & @CRLF & _
"# Ubuntu OpenStack" & @CRLF & _
"LABEL=cloudimg-rootfs / ext4 defaults 0 0" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"# Centos" & @CRLF & _
"/dev/mapper/VolGroup00-lv_slash / xfs defaults 0 0" & @CRLF & _
"UUID=4534700a-a2b2-4d6c-9415-c372da0c39eb /boot xfs defaults 0 0" & @CRLF & _
"/dev/mapper/VolGroup00-lv_home /home xfs defaults 0 0" & @CRLF & _
"/dev/mapper/VolGroup00-lv_tmp /tmp xfs defaults 0 0" & @CRLF & _
"/dev/mapper/VolGroup00-lv_var /var xfs defaults 0 0" & @CRLF & _
"/dev/mapper/VolGroup00-lv_swap swap swap defaults 0 0" & @CRLF & _
"" & @CRLF & _
"# Debian 7" & @CRLF & _
"/dev/mapper/VolGroup00-root / ext4 errors=remount-ro 0 1" & @CRLF & _
"# /boot was on /dev/sda1 during installation" & @CRLF & _
"UUID=080670e3-93d1-4fdc-be7d-d8b05ad6d1e5 /boot ext4 defaults 0 2" & @CRLF & _
"/dev/mapper/VolGroup00-home /home ext4 defaults 0 2" & @CRLF & _
"/dev/mapper/VolGroup00-tmp /tmp ext4 defaults 0 2" & @CRLF & _
"/dev/mapper/VolGroup00-var /var ext4 defaults 0 2" & @CRLF & _
"/dev/mapper/VolGroup00-swap_1 none swap sw 0 0" & @CRLF & _
"/dev/sr0 /media/cdrom0 udf,iso9660 user,noauto 0 0" & @CRLF & _
"/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"# Debian 8" & @CRLF & _
"/dev/mapper/VolGroup00-root / ext4 errors=remount-ro 0 1" & @CRLF & _
"# /boot was on /dev/sda1 during installation" & @CRLF & _
"UUID=18b29bfa-332a-409b-810c-5cc8a1dbb81e /boot ext4 defaults 0 2" & @CRLF & _
"/dev/mapper/VolGroup00-home /home ext4 defaults 0 2" & @CRLF & _
"/dev/mapper/VolGroup00-tmp /tmp ext4 defaults 0 2" & @CRLF & _
"/dev/mapper/VolGroup00-var /var ext4 defaults 0 2" & @CRLF & _
"/dev/mapper/VolGroup00-swap_1 none swap sw 0 0" & @CRLF & _
"/dev/sr0 /media/cdrom0 udf,iso9660 user,noauto 0 0" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")