import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*ext[2-4]|.*xfs)(\\s+)((([a-zA-Z\\=\\-]+)(?!noatime,nodireatime)).+)";
final String string = "# Not match\n"
+ "/dev/mapper/VolGroup00-root / ext4 errors=remount-ro,noatime,nodiratime 0 1\n"
+ "/dev/mapper/VolGroup00-home /home ext4 defaults,noatime,nodiratime 0 2\n"
+ "LABEL=cloudimg-rootfs / ext4 defaults,noatime,nodiratime 0 0\n\n"
+ "# /etc/fstab: static file system information.\n"
+ "#\n"
+ "# Use 'blkid' to print the universally unique identifier for a\n"
+ "# device; this may be used with UUID= as a more robust way to name devices\n"
+ "# that works even if disks are added and removed. See fstab(5).\n"
+ "#\n"
+ "# <file system> <mount point> <type> <options> <dump> <pass>\n"
+ "/dev/mapper/VolGroup00-root / ext4 errors=remount-ro 0 1\n"
+ "# /boot was on /dev/sda1 during installation\n"
+ "UUID=72836e37-44d4-4612-90ef-0e545a0071a6 /boot ext4 defaults 0 2\n"
+ "/dev/mapper/VolGroup00-home /home ext4 defaults 0 2\n"
+ "/dev/mapper/VolGroup00-tmp /tmp ext4 defaults 0 2\n"
+ "/dev/mapper/VolGroup00-var /var ext4 defaults 0 2\n"
+ "/dev/mapper/VolGroup00-swap_1 none swap sw 0 0\n"
+ "/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0\n\n"
+ "# Ubuntu OpenStack\n"
+ "LABEL=cloudimg-rootfs / ext4 defaults 0 0\n\n\n"
+ "# Centos\n"
+ "/dev/mapper/VolGroup00-lv_slash / xfs defaults 0 0\n"
+ "UUID=4534700a-a2b2-4d6c-9415-c372da0c39eb /boot xfs defaults 0 0\n"
+ "/dev/mapper/VolGroup00-lv_home /home xfs defaults 0 0\n"
+ "/dev/mapper/VolGroup00-lv_tmp /tmp xfs defaults 0 0\n"
+ "/dev/mapper/VolGroup00-lv_var /var xfs defaults 0 0\n"
+ "/dev/mapper/VolGroup00-lv_swap swap swap defaults 0 0\n\n"
+ "# Debian 7\n"
+ "/dev/mapper/VolGroup00-root / ext4 errors=remount-ro 0 1\n"
+ "# /boot was on /dev/sda1 during installation\n"
+ "UUID=080670e3-93d1-4fdc-be7d-d8b05ad6d1e5 /boot ext4 defaults 0 2\n"
+ "/dev/mapper/VolGroup00-home /home ext4 defaults 0 2\n"
+ "/dev/mapper/VolGroup00-tmp /tmp ext4 defaults 0 2\n"
+ "/dev/mapper/VolGroup00-var /var ext4 defaults 0 2\n"
+ "/dev/mapper/VolGroup00-swap_1 none swap sw 0 0\n"
+ "/dev/sr0 /media/cdrom0 udf,iso9660 user,noauto 0 0\n"
+ "/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0\n\n\n\n"
+ "# Debian 8\n"
+ "/dev/mapper/VolGroup00-root / ext4 errors=remount-ro 0 1\n"
+ "# /boot was on /dev/sda1 during installation\n"
+ "UUID=18b29bfa-332a-409b-810c-5cc8a1dbb81e /boot ext4 defaults 0 2\n"
+ "/dev/mapper/VolGroup00-home /home ext4 defaults 0 2\n"
+ "/dev/mapper/VolGroup00-tmp /tmp ext4 defaults 0 2\n"
+ "/dev/mapper/VolGroup00-var /var ext4 defaults 0 2\n"
+ "/dev/mapper/VolGroup00-swap_1 none swap sw 0 0\n"
+ "/dev/sr0 /media/cdrom0 udf,iso9660 user,noauto 0 0\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}