const regex = new RegExp('^(.*ext[2-4]|.*xfs)(\\s+)((([a-zA-Z\\=\\-]+)(?!noatime,nodireatime)).+)', 'gm')
const str = `# Not match
/dev/mapper/VolGroup00-root / ext4 errors=remount-ro,noatime,nodiratime 0 1
/dev/mapper/VolGroup00-home /home ext4 defaults,noatime,nodiratime 0 2
LABEL=cloudimg-rootfs / ext4 defaults,noatime,nodiratime 0 0
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
/dev/mapper/VolGroup00-root / ext4 errors=remount-ro 0 1
# /boot was on /dev/sda1 during installation
UUID=72836e37-44d4-4612-90ef-0e545a0071a6 /boot ext4 defaults 0 2
/dev/mapper/VolGroup00-home /home ext4 defaults 0 2
/dev/mapper/VolGroup00-tmp /tmp ext4 defaults 0 2
/dev/mapper/VolGroup00-var /var ext4 defaults 0 2
/dev/mapper/VolGroup00-swap_1 none swap sw 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
# Ubuntu OpenStack
LABEL=cloudimg-rootfs / ext4 defaults 0 0
# Centos
/dev/mapper/VolGroup00-lv_slash / xfs defaults 0 0
UUID=4534700a-a2b2-4d6c-9415-c372da0c39eb /boot xfs defaults 0 0
/dev/mapper/VolGroup00-lv_home /home xfs defaults 0 0
/dev/mapper/VolGroup00-lv_tmp /tmp xfs defaults 0 0
/dev/mapper/VolGroup00-lv_var /var xfs defaults 0 0
/dev/mapper/VolGroup00-lv_swap swap swap defaults 0 0
# Debian 7
/dev/mapper/VolGroup00-root / ext4 errors=remount-ro 0 1
# /boot was on /dev/sda1 during installation
UUID=080670e3-93d1-4fdc-be7d-d8b05ad6d1e5 /boot ext4 defaults 0 2
/dev/mapper/VolGroup00-home /home ext4 defaults 0 2
/dev/mapper/VolGroup00-tmp /tmp ext4 defaults 0 2
/dev/mapper/VolGroup00-var /var ext4 defaults 0 2
/dev/mapper/VolGroup00-swap_1 none swap sw 0 0
/dev/sr0 /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
# Debian 8
/dev/mapper/VolGroup00-root / ext4 errors=remount-ro 0 1
# /boot was on /dev/sda1 during installation
UUID=18b29bfa-332a-409b-810c-5cc8a1dbb81e /boot ext4 defaults 0 2
/dev/mapper/VolGroup00-home /home ext4 defaults 0 2
/dev/mapper/VolGroup00-tmp /tmp ext4 defaults 0 2
/dev/mapper/VolGroup00-var /var ext4 defaults 0 2
/dev/mapper/VolGroup00-swap_1 none swap sw 0 0
/dev/sr0 /media/cdrom0 udf,iso9660 user,noauto 0 0
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}