#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<type>build)(?<scope>\(.*\)?(?=:))?(?<breaking>!)?(?<subject>:.*)?"
Local $sString = "build(one)" & @CRLF & _
"build(two)!" & @CRLF & _
"build(three)!:test" & @CRLF & _
"build(example:module)!: test subject" & @CRLF & _
"build: test" & @CRLF & _
"build(<> : dda!sd): test" & @CRLF & _
"build(:" & @CRLF & _
"build"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")