re = /(?<type>build)(?<scope>\(.*\)?(?=:))?(?<breaking>!)?(?<subject>:.*)?/m
str = 'build(one)
build(two)!
build(three)!:test
build(example:module)!: test subject
build: test
build(<> : dda!sd): test
build(:
build'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end