using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<type>build)(?<scope>\(.*\)?(?=:))?(?<breaking>!)?(?<subject>:.*)?";
string input = @"build(one)
build(two)!
build(three)!:test
build(example:module)!: test subject
build: test
build(<> : dda!sd): test
build(:
build";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}