import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<type>build)(?<scope>\\(.*\\)?(?=\\)|:))?(?<breaking>!)?(?<subject>:.*)?";
final String string = "build(one)\n"
+ "build(two)!\n"
+ "build(three)!:test\n"
+ "build(example:module)!: test subject\n"
+ "build: test\n"
+ "build(<> : dda!sd): test\n"
+ "build(:\n"
+ "build";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}