const regex = /(?<type>build)(?<scope>\(.*\)?(?=\)|:))?(?<breaking>!)?(?<subject>:.*)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<type>build)(?<scope>\\(.*\\)?(?=\\)|:))?(?<breaking>!)?(?<subject>:.*)?', 'gm')
const str = `build(one)
build(two)!
build(three)!:test
build(example:module)!: test subject
build: test
build(<> : dda!sd): test
build(:
build`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}