import re
regex = re.compile(r"(?<type>build)(?<scope>\(.*\)?(?=\)|:))?(?<breaking>!)?(?<subject>:.*)?", flags=re.MULTILINE)
test_str = ("build(one)\n"
"build(two)!\n"
"build(three)!:test\n"
"build(example:module)!: test subject\n"
"build: test\n"
"build(<> : dda!sd): test\n"
"build(:\n"
"build")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")