using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([1-9][0-9]*)$";
string input = @"000055448540
000000015000
0010000000
50
08
05
# does not work, it returns leading zeros as match.
# (?:^0+)|(\d+)$";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}