const regex = /([1-9][0-9]*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([1-9][0-9]*)$', 'gm')
const str = `000055448540
000000015000
0010000000
50
08
05
# does not work, it returns leading zeros as match.
# (?:^0+)|(\\d+)\$`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}