$re = '/([1-9][0-9]*)$/m';
$str = '000055448540
000000015000
0010000000
50
08
05
# does not work, it returns leading zeros as match.
# (?:^0+)|(\\d+)$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);