package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[0-9]+[.,][0-9]{2}`)
var str = `10,00
100,00
1000,00
10.000,00
1.000,00
10.000,00
100.000,00
1000.000.00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}