import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]+[.,][0-9]{2}";
final String string = "10,00 \n"
+ "100,00\n"
+ "1000,00\n"
+ "10.000,00\n"
+ "1.000,00\n"
+ "10.000,00\n"
+ "100.000,00\n"
+ "1000.000.00";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}