$re = '/[0-9]+[.,][0-9]{2}/';
$str = '10,00
100,00
1000,00
10.000,00
1.000,00
10.000,00
100.000,00
1000.000.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);