#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:[\d]-?){7,})"
Local $sString = "import pandas as pd" & @CRLF & _
"df = pd.DataFrame({'Text':['This person num is 111-888-8780 and other'," & @CRLF & _
" 'dont block 23 here'," & @CRLF & _
" 'two numbers: 001-002-1234 and some other 123-456-7788 here'," & @CRLF & _
" 'block this 666-666-6666'," & @CRLF & _
" '1-510-999-9999 is one more'], " & @CRLF & _
" 'P_ID': [1,2,3,4,5]," & @CRLF & _
" 'N_ID' : ['A1', 'A2', 'A3','A4', 'A5']})" & @CRLF & _
"123-452"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")