// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((?:[\d]-?){7,})").unwrap();
let string = "import pandas as pd
df = pd.DataFrame({'Text':['This person num is 111-888-8780 and other',
'dont block 23 here',
'two numbers: 001-002-1234 and some other 123-456-7788 here',
'block this 666-666-6666',
'1-510-999-9999 is one more'],
'P_ID': [1,2,3,4,5],
'N_ID' : ['A1', 'A2', 'A3','A4', 'A5']})
123-452";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}