use strict;
my $str = 'import pandas as pd
df = pd.DataFrame({\'Text\':[\'This person num is 111-888-8780 and other\',
\'dont block 23 here\',
\'two numbers: 001-002-1234 and some other 123-456-7788 here\',
\'block this 666-666-6666\',
\'1-510-999-9999 is one more\'],
\'P_ID\': [1,2,3,4,5],
\'N_ID\' : [\'A1\', \'A2\', \'A3\',\'A4\', \'A5\']})
123-452';
my $regex = qr/((?:[\d]-?){7,})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}