import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:https?:\\/\\/)?(?:(\\w+)\\.){1,}\\w+(?:\\/.*){1,}\\.(?:jpg|gif|png)";
final String string = "Veja minha imagem aqui: www.imagem.com.br/imagem.jpg\n"
+ "Esta é uma imagem bacana http://imagens.com.br/imagens/teste/imagem.png\n"
+ "Esta aqui é uma outra super imagem subdominio.website.com.br/imagens/teste/opa.gif\n\n"
+ "Aqui está uma outra imageim: https://subdominio.com.br/imagens-teste.png";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}