import Foundation
let pattern = #"(?:https?:\/\/)?(?:(\w+)\.){1,}\w+(?:\/.*){1,}\.(?:jpg|gif|png)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Veja minha imagem aqui: www.imagem.com.br/imagem.jpg
Esta é uma imagem bacana http://imagens.com.br/imagens/teste/imagem.png
Esta aqui é uma outra super imagem subdominio.website.com.br/imagens/teste/opa.gif
Aqui está uma outra imageim: https://subdominio.com.br/imagens-teste.png
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
    var groups: [String] = []
    for rangeIndex in 1 ..< match.numberOfRanges {
        let nsRange = match.range(at: rangeIndex)
        guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
        let string = (testString as NSString).substring(with: nsRange)
        groups.append(string)
    }
    if !groups.isEmpty {
        result.append(groups)
    }
}
print(result)