# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:https?:\/\/)?(?:(\w+)\.){1,}\w+(?:\/.*){1,}\.(?:jpg|gif|png)"
test_str = ("Veja minha imagem aqui: www.imagem.com.br/imagem.jpg\n"
"Esta é uma imagem bacana http://imagens.com.br/imagens/teste/imagem.png\n"
"Esta aqui é uma outra super imagem subdominio.website.com.br/imagens/teste/opa.gif\n\n"
"Aqui está uma outra imageim: https://subdominio.com.br/imagens-teste.png")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.