using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ro|p|c";
string input = @"red
orange
yellow
green
blue
indigo
violet
purple
brown
pink
cyan
maroon";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}