$re = '/ro|p|c/m';
$str = 'red
orange
yellow
green
blue
indigo
violet
purple
brown
pink
cyan
maroon';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);