import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ro|p|c";
final String string = "red\n"
+ "orange\n"
+ "yellow\n"
+ "green\n"
+ "blue\n"
+ "indigo\n"
+ "violet\n\n"
+ "purple\n"
+ "brown\n"
+ "pink\n"
+ "cyan\n"
+ "maroon";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}