#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w+(?<!_min)\.(jpg|gif)"
Local $sString = "desc_125f.jpg -> matched," & @CRLF & _
"desc#_56.jpg -> not matched (contains #)," & @CRLF & _
"bla_bla.gif -> matched," & @CRLF & _
"bla_bla.png -> not matched (extension is png)," & @CRLF & _
"desc_125f_min.jpg -> not matched (contains _min between a filename and an extension)," & @CRLF & _
"desc_min256.gif"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")