import Foundation
let pattern = #"^\w+(?<!_min)\.(jpg|gif)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
desc_125f.jpg -> matched,
desc#_56.jpg -> not matched (contains #),
bla_bla.gif -> matched,
bla_bla.png -> not matched (extension is png),
desc_125f_min.jpg -> not matched (contains _min between a filename and an extension),
desc_min256.gif
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)