#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=Create a file containing just this data:\n\n)(?<filedata>[\w.-]+)(?:[\w\W]+?http:\/\/website.su\/\.well-known\/acme-challenge\/)(?<filename>\w+)"
Local $sString = "Create a file containing just this data:" & @CRLF & _
"" & @CRLF & _
"onGlaTwqHns4p9sU36HYrGmEwompIV5GcB9kUXnLMTM.5-VMGAJ-Ns73VGuK8oiDpcVUHbW3Y_vfMMoF1VIpSDI" & @CRLF & _
"" & @CRLF & _
"And make it available on your web server at this URL:" & @CRLF & _
"" & @CRLF & _
"http://website.su/.well-known/acme-challenge/onGlaTwqHns4p9sU36HYrGmEwompIV5GcB9kUXnLMT"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")