re = /(?<=Create a file containing just this data:\n\n)(?<filedata>[\w.-]+)(?:[\w\W]+?http:\/\/website.su\/\.well-known\/acme-challenge\/)(?<filename>\w+)/m
str = 'Create a file containing just this data:
onGlaTwqHns4p9sU36HYrGmEwompIV5GcB9kUXnLMTM.5-VMGAJ-Ns73VGuK8oiDpcVUHbW3Y_vfMMoF1VIpSDI
And make it available on your web server at this URL:
http://website.su/.well-known/acme-challenge/onGlaTwqHns4p9sU36HYrGmEwompIV5GcB9kUXnLMT'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end