import Foundation
let pattern = #"(?<=Create a file containing just this data:\n\n)(?<filedata>[\w.-]+)(?:[\w\W]+?http:\/\/website.su\/\.well-known\/acme-challenge\/)(?<filename>\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Create a file containing just this data:
onGlaTwqHns4p9sU36HYrGmEwompIV5GcB9kUXnLMTM.5-VMGAJ-Ns73VGuK8oiDpcVUHbW3Y_vfMMoF1VIpSDI
And make it available on your web server at this URL:
http://website.su/.well-known/acme-challenge/onGlaTwqHns4p9sU36HYrGmEwompIV5GcB9kUXnLMT
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)