package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d+(?:\.\d+)?\b(*SKIP)(*F)|\d`)
var str = `my text contains of the 33109 following values RT3123SO55 and also with certain numbers godwil_5708 and 323stwe and 8y9yc2 456453`
var substitution = "*"
fmt.Println(re.ReplaceAllString(str, substitution))
}