$re = '/\b\d+(?:\.\d+)?\b(*SKIP)(*F)|\d/m';
$str = 'my text contains of the 33109 following values RT3123SO55 and also with certain numbers godwil_5708 and 323stwe and 8y9yc2 456453';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;