#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?msi)<div>((?:<div[^>]*>(?1)<\/div>|[^<]*|<(?!div))*)<\/div>"
Local $sString = "<div>" & @CRLF & _
" Lorem ipsum dolor sit amet" & @CRLF & _
"</div>" & @CRLF & _
"<div>" & @CRLF & _
" Lorem ipsum dolor sit amet" & @CRLF & _
"</div>" & @CRLF & _
"<div>" & @CRLF & _
" <div class="media_embed">" & @CRLF & _
" <div style="xxx">" & @CRLF & _
" <div style="xxx">" & @CRLF & _
" <div style="xxx"></div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
"</div>" & @CRLF & _
"<div>" & @CRLF & _
" Lorem ipsum dolor sit amet" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<div class="foo">" & @CRLF & _
"<div>FOO</div>" & @CRLF & _
"" & @CRLF & _
" <div class="bar">" & @CRLF & _
" <div>BAR</div>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" <div>FOOBAR<div class="foobar"></div></div>" & @CRLF & _
"" & @CRLF & _
" <div class="bar"><div><b>BAR</b></div></div>" & @CRLF & _
"" & @CRLF & _
" <!-- para este caso, deberás ejecutar preg_replace " & @CRLF & _
" hasta que no haya nada nuevo por reemplazar -->" & @CRLF & _
" <div><div>foobar</div></div>" & @CRLF & _
"</div>"
Local $sSubst = "<p>$1</p>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)