re = /<div>((?:<div[^>]*>(?1)<\/div>|[^<]*|<(?!div))*)<\/div>/mi
str = '<div>
Lorem ipsum dolor sit amet
</div>
<div>
Lorem ipsum dolor sit amet
</div>
<div>
<div class="media_embed">
<div style="xxx">
<div style="xxx">
<div style="xxx"></div>
</div>
</div>
</div>
</div>
<div>
Lorem ipsum dolor sit amet
</div>
<div class="foo">
<div>FOO</div>
<div class="bar">
<div>BAR</div>
</div>
<div>FOOBAR<div class="foobar"></div></div>
<div class="bar"><div><b>BAR</b></div></div>
<!-- para este caso, deberás ejecutar preg_replace
hasta que no haya nada nuevo por reemplazar -->
<div><div>foobar</div></div>
</div>'
subst = '<p>$1</p>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result