import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div>((?:<div[^>]*>(?1)<\\/div>|[^<]*|<(?!div))*)<\\/div>";
final String string = "<div>\n"
+ " Lorem ipsum dolor sit amet\n"
+ "</div>\n"
+ "<div>\n"
+ " Lorem ipsum dolor sit amet\n"
+ "</div>\n"
+ "<div>\n"
+ " <div class=\"media_embed\">\n"
+ " <div style=\"xxx\">\n"
+ " <div style=\"xxx\">\n"
+ " <div style=\"xxx\"></div>\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n"
+ "</div>\n"
+ "<div>\n"
+ " Lorem ipsum dolor sit amet\n"
+ "</div>\n\n\n\n\n\n"
+ "<div class=\"foo\">\n"
+ "<div>FOO</div>\n\n"
+ " <div class=\"bar\">\n"
+ " <div>BAR</div>\n"
+ " </div>\n\n"
+ " <div>FOOBAR<div class=\"foobar\"></div></div>\n\n"
+ " <div class=\"bar\"><div><b>BAR</b></div></div>\n\n"
+ " <!-- para este caso, deberás ejecutar preg_replace \n"
+ " hasta que no haya nada nuevo por reemplazar -->\n"
+ " <div><div>foobar</div></div>\n"
+ "</div>";
final String subst = "<p>$1</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}