const regex = /^\/\?p=([0-9]{0,3}:)([0-9]{0,4})+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/\\?p=([0-9]{0,3}:)([0-9]{0,4})+', 'g')
const str = `/?p=899:2000:15018702722302::NO:::`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}