$re = '/^\/\?p=([0-9]{0,3}:)([0-9]{0,4})+/';
$str = '/?p=899:2000:15018702722302::NO:::';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);