// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^\/\?p=([0-9]{0,3}:)([0-9]{0,4})+").unwrap();
let string = "/?p=899:2000:15018702722302::NO:::";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}