# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/}|(?=\s*#\s*(?:elif|else|endif)\b)//gm;t' <<< "if (1 === 1) {
#ifdef DIRECTIVE
#endif
}
"