use strict;
my $str = 'if (1 === 1) {
#ifdef DIRECTIVE
#endif
}
';
my $regex = qr/}|(?=\s*#\s*(?:elif|else|endif)\b)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";