const regex = /}|(?=\s*#\s*(?:elif|else|endif)\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('}|(?=\\s*#\\s*(?:elif|else|endif)\\b)', 'gm')
const str = `if (1 === 1) {
#ifdef DIRECTIVE
#endif
}
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);