import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[Ii][Nn][Vv][Oo][Ii][Cc][Ee](?:[[:punct:]]*\\s*)*(.*)$";
final String string = "Part Lot.: SIM\n"
+ "Telex Release.: SIM\n"
+ "Sea Waybill.: SIM\n"
+ "L/C(Cart. Crédito).: SIM\n"
+ "DU.: SIM - TEST Fer 15:11\n"
+ "PIP.: SIM - pip\n"
+ "MOZ.: SIM\n"
+ "PIV.: SIM - TESTE 123\n"
+ "Incoterms.: SIM\n"
+ "SKU Espelho.: SIM\n"
+ "Inspeção.: SIM\n"
+ "Etiqueta.: SIM\n"
+ "Invoice.: .: teste Fer 15:11\n"
+ "Packing list.: teste Fer 15:11\n"
+ "teste Lisa 15:11\n"
+ "Quantidade CNTR.: SIM - 000123";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}