import re
regex = re.compile(r"^[Ii][Nn][Vv][Oo][Ii][Cc][Ee](?:[[:punct:]]*\s*)*(.*)$")
test_str = ("Part Lot.: SIM\n"
"Telex Release.: SIM\n"
"Sea Waybill.: SIM\n"
"L/C(Cart. Crédito).: SIM\n"
"DU.: SIM - TEST Fer 15:11\n"
"PIP.: SIM - pip\n"
"MOZ.: SIM\n"
"PIV.: SIM - TESTE 123\n"
"Incoterms.: SIM\n"
"SKU Espelho.: SIM\n"
"Inspeção.: SIM\n"
"Etiqueta.: SIM\n"
"Invoice.: .: teste Fer 15:11\n"
"Packing list.: teste Fer 15:11\n"
"teste Lisa 15:11\n"
"Quantidade CNTR.: SIM - 000123")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")