import re
regex = re.compile(r"(^[^\[]+|\][^\]]+$)|\s+", flags=re.MULTILINE)
test_str = "a b c [a b c] d e f"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)