re = /(^[^\[]+|\][^\]]+$)|\s+/m
str = 'a b c [a b c] d e f'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result