#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""([^"]+)":"
Local $sString = "{" & @CRLF & _
" "activity:status": "BOOKED"," & @CRLF & _
" "criteria:duration": 8," & @CRLF & _
" "criteria:tripFrom": 1500242400," & @CRLF & _
" "criteria:tripTo": 1500933600," & @CRLF & _
" "intent:booker": 0.06258322237017303," & @CRLF & _
" "intent:churnRisk": 0.3004193725304727," & @CRLF & _
" "intent:churnRiskText": "LOW"," & @CRLF & _
" "intent:userClass": "CUSTOMER"," & @CRLF & _
" "issues:acs": 14," & @CRLF & _
" "issues:total": 0," & @CRLF & _
" "revenue": 2896," & @CRLF & _
" "tracking:events": 162," & @CRLF & _
" "tracking:firstVisit": 1475320136," & @CRLF & _
" "tracking:lastVisit": 1498054362," & @CRLF & _
" "tracking:sessions30": 19," & @CRLF & _
" "tracking:timeSpent": 10603," & @CRLF & _
" "value:potentialRevenue": {" & @CRLF & _
" "mean": 2880.5258186397987," & @CRLF & _
" "stddev": 504.1184773012633," & @CRLF & _
" "weight": 1," & @CRLF & _
" "confidence": 1" & @CRLF & _
" }," & @CRLF & _
" "criteria:occupancy": {" & @CRLF & _
" "adults": 2," & @CRLF & _
" "children": 2," & @CRLF & _
" "infants": 0" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")