import Foundation
let pattern = #""([^"]+)":"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{
"activity:status": "BOOKED",
"criteria:duration": 8,
"criteria:tripFrom": 1500242400,
"criteria:tripTo": 1500933600,
"intent:booker": 0.06258322237017303,
"intent:churnRisk": 0.3004193725304727,
"intent:churnRiskText": "LOW",
"intent:userClass": "CUSTOMER",
"issues:acs": 14,
"issues:total": 0,
"revenue": 2896,
"tracking:events": 162,
"tracking:firstVisit": 1475320136,
"tracking:lastVisit": 1498054362,
"tracking:sessions30": 19,
"tracking:timeSpent": 10603,
"value:potentialRevenue": {
"mean": 2880.5258186397987,
"stddev": 504.1184773012633,
"weight": 1,
"confidence": 1
},
"criteria:occupancy": {
"adults": 2,
"children": 2,
"infants": 0
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)