# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"([^\"]+)\":"
test_str = ("{\n"
" \"activity:status\": \"BOOKED\",\n"
" \"criteria:duration\": 8,\n"
" \"criteria:tripFrom\": 1500242400,\n"
" \"criteria:tripTo\": 1500933600,\n"
" \"intent:booker\": 0.06258322237017303,\n"
" \"intent:churnRisk\": 0.3004193725304727,\n"
" \"intent:churnRiskText\": \"LOW\",\n"
" \"intent:userClass\": \"CUSTOMER\",\n"
" \"issues:acs\": 14,\n"
" \"issues:total\": 0,\n"
" \"revenue\": 2896,\n"
" \"tracking:events\": 162,\n"
" \"tracking:firstVisit\": 1475320136,\n"
" \"tracking:lastVisit\": 1498054362,\n"
" \"tracking:sessions30\": 19,\n"
" \"tracking:timeSpent\": 10603,\n"
" \"value:potentialRevenue\": {\n"
" \"mean\": 2880.5258186397987,\n"
" \"stddev\": 504.1184773012633,\n"
" \"weight\": 1,\n"
" \"confidence\": 1\n"
" },\n"
" \"criteria:occupancy\": {\n"
" \"adults\": 2,\n"
" \"children\": 2,\n"
" \"infants\": 0\n"
" }\n"
"}")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.